Jump to content


Photo

FoxPro battery help


  • Please log in to reply
6 replies to this topic

#1 204destroyer

204destroyer

    Predator

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:central california

Posted 14 December 2010 - 04:16 PM

I have the FOXPRO FX5, and I got tired of messing with those little AA batteries, so I ordered the heavy duty gel filled bag battery from Foxpro, I disconnect the inside batteries and remove them as instructed, I plug the charger that came with the gel battery and the light on the charger comes on green instead of red like the instructions say it will. When first hooked up the light will be red. when the battery is charged the light turns green, you can now plug this battery into the charge jack on the side of the caller and bingo, you have long lasting power, ha ha right, I get nothin at all, my caller will not even come on at all. Ive tried it about 10 times and nothing. ANY IDEAS??Thanks

#2 fyrewil

fyrewil

    Predator

  • Members
  • PipPipPipPip
  • 262 posts
  • Gender:Male
  • Location:NV

Posted 14 December 2010 - 04:30 PM

Have the battery pack climatized before charging? (room temp)Or you may have a short in your new pack.....(battery)2cents

#3 OrneryOlMofo357

OrneryOlMofo357

    Tikka Shooter, and a bad shot at that.

  • Gold Contributor
  • PipPipPipPipPipPipPip
  • 5,115 posts
  • Gender:Male
  • Location:Nevada

Posted 14 December 2010 - 05:16 PM

Check with DABob.. he too uses a battery pack. See what he uses, he prolly has some insight. I have never had any problems with my FX5, except that when I recieved the Car charger it never worked. Foxpro sent me a new one. Have you got a volt meter? Check the charger, battery and the new cord that goes into the Foxpro maybe there is a short that can be easily remidied. Good Luck.

#4 204destroyer

204destroyer

    Predator

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:central california

Posted 14 December 2010 - 05:19 PM

Thanks I'll try all that. My more expensive charger says the battery is at full charge, so something isnt making contact.Thanks

#5 204destroyer

204destroyer

    Predator

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:central california

Posted 14 December 2010 - 06:42 PM

Well I think I got it. Checked the continuity at the charger plug in and there is no connection at the other end of the hot wire (internal problems). Boy couldn't come at a worse time. Called me a couple of yotes Sunday, got them both and was dying to go back. Thanks for your help.

#6 mtn dog

mtn dog

    Big Shooter

  • Members
  • PipPipPipPipPipPip
  • 1,757 posts
  • Gender:Male
  • Location:Camino, CA
  • Interests:Predator hunting.
    Other interests:
    My family, writing, photography, 2nd Amendment.
    Looking forward to meeting as many of you as possible.

Posted 14 December 2010 - 08:42 PM

Hey, no worries. Just post the exact location and someone from here, maybe several someones, will rush out and check on your coyotes for you while you get your caller fixed. :smiley_kewlpics:

#7 204destroyer

204destroyer

    Predator

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:central california

Posted 15 December 2010 - 04:25 PM

Hey these guys at foxpro are alright. I shipped it out today (2 day delivery), he said they would only have it 24 hrs. and it would be on its way back to me. He agreed it has some internal problems. I here they are good for their word, so those yotes will wait on me. Sorry mtn dog, maybe next time.Good hunting to all.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users