Sign in to follow this  
Followers 0
Stiff Neck

Is my FOXPRO broke?

4 posts in this topic

My FOXPRO unit is malfunctioning when downloading sounds from my computer onto the 416B unit. I purchased 16 sounds from the web site and put them on CD. No problems here. I'm following the directions to the "T" using the PG-1A programmer. Sounds 1-8 play perfectly for all 30 seconds after programing them. The problem is that when I record a sound on position 1, it records onto position 1 AND position 9. Also: Position 2 records onto position 2 AND 10. Position 3 records onto position 3 AND 11. Position 4 records onto position 4 AND 12. Position 5 records onto position 5 AND 13. Position 6 records onto position 6 AND 13. Position 9 records onto the second half of position 1. Position 10 records onto the second half of position 2. And so forth. It messes with the dial position exactly opposite of the dial position being recorded onto. The dial is NOT loose, it functions fine. The result was utter confusion at first. So I re-recorded the whole thing, mixing up some of the sounds. Same thing happened. I tried it again, and again, each time I'd record the sound, unplug the unit, turn it off, then test the sound. I spent 3 HOURS last night trying to figure out what the heck is going wrong, and it's driving me absolutely NUTS. As a result of the sounds recording in the wrong places, some of the original sounds on my unit that I wanted to keep have been recorded over. I'll have to purchase about 6 sounds to replace them. Can somebody PLEASE help me? Is my unit broken?

Share this post


Link to post
Share on other sites

Stiffneck,I have the FX3, so I can't assist with your specific issue. I would call (not email) Mike Dillon or one of his tech's at Foxpro. I know there way behind in the shop, but they are usually very responsive. You could request help through their website, but again they are way behind with production. I think they are changng servers again a well. Good luck.Mike

Share this post


Link to post
Share on other sites

I replaced all the batteries with brand new ones even though the old ones still had juice in them. Now it works fine. I guess I need to order 16 more sounds to replace the ones that I lost... When it works right, it's REALLY easy to record new sounds onto the unit from your computer/CD. WOW, no need to buy a 32 sound unit if you can just swap out the sounds for different seasons or hunts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0