Sign in to follow this  
Followers 0
5150Marcelo

Foxpro TX 500 Remote HELP!

25 posts in this topic

I bought a Foxpro Fury GX7 from a hunting and fishing supply store. Its about a month old. Now the TX-500 remote shows my sound list all scrambled no words show up and nothing plays. The remote is displaying everything else fine except the sound list and won't play anything. The menu on the remote works fine, I did the sound list upload and it says it uploads it but still the sound list is scrambled and won't play anything. Is there any way to reset the remote or what?The caller works great when using it by itself, but the remote is acting funky. tx500.jpg:signs1242cn:

Share this post


Link to post
Share on other sites
Mine did that once i just downloaded new playlist to the tx-500 tells you how in the manual.
I did that. Stays the same.

Share this post


Link to post
Share on other sites
I seem to remember having similar troubles with my TX200 remote.
I remember. I fixed it for you. Luckily you brought your mexican that day. :signs1242cn:
Just call FoxPro and they'll handle it for you. They are the best at service.
I would, but theyre closed till monday. Im headed out to AZ tomorrow and wanted to fool around with it a bit.

Share this post


Link to post
Share on other sites

There is a Fox Pro forum. Go there and wander about, maybe somebody has has the same problem.

Share this post


Link to post
Share on other sites
There is a Fox Pro forum. Go there and wander about, maybe somebody has has the same problem.
Why Braz, are you telling me to scram????? LOL! JKYea, I went there and there was a guy with a similar problem, but a FP member said to call him direct. Doesnt say if/how he got it resolved.

Share this post


Link to post
Share on other sites

Man, that plain sucks, but Foxpro will take care of it, and quickly too...Guess it's too late to buy a SPARE Foxpro call of some kind? And is what I did. Actually I have 3 e callers, but 2 are Foxpro. Also why it's a good idea to ALWAYS have a (reliable) mouth call or two on stand with you. Never know when an e caller will go on the blink.Good Luck on Your Arizona hunt this weekend. This last week had me thinking about running out there myself. Now you really got me going. lolLet us know how you doFrank

Share this post


Link to post
Share on other sites

Did you try removing the batteries and then reinstalling them. Sometimes it's the simple fixes.

Share this post


Link to post
Share on other sites

I just recently got a new fox pro. I screwed up my remote some how. I think it was from not holding down the button long enough when starting it up. The guy that helped me fix mine says this can happen some times if you do not hold down the button long enough when starting it up and then push a series of buttons. My screen went completely dark though. I called Allpredatorcalls where I bought it and they walked me through how to fix it on the phone. I do not know if this is the same thing though my screen looked different than yours when it was messed up. I had to link the call to the remote with a cable and reload the calls back on to the remote.

Share this post


Link to post
Share on other sites

Marcelo, you don't need to be racist. I use mexicans to clean my house and do my yardwork as well as hunt with them, so as you can see I am not picky about who I work or hunt with.

Share this post


Link to post
Share on other sites
Did you try removing the batteries and then reinstalling them. Sometimes it's the simple fixes.
BINGO... and is exactly what happened to me once, and it cured the problem. Even then, that incident still made me go out and buy the spitfire as a spare. LOLI thought about mentioning that, but then thought NAW, just HAS to be something else. LOL So glad ShooterJohn said it!

Share this post


Link to post
Share on other sites

Back from AZ. Didnt hunt. I was out there for a party. It was on the outskirts of town and I KNOW theryre coyotes there. I just wanted to fool with the caller a bit and see if I cant get them to sing. Anyway, yea. I tried pulling the batteries already, but no cigar. I'll give Foxpro a call manana.

Share this post


Link to post
Share on other sites

Shucks, I always hope pulling the batteries will do it. I'm sure they'll make it right either way good luck Marcelo. Hey look at it like this. Your callers just acting up but PCH bit the BIG one! :signs1242cn:

Share this post


Link to post
Share on other sites

Same thing happened to mine. I had to send it in.They just got it today and said they will have it fixed in less than two days.I would give them a call,Matt

Share this post


Link to post
Share on other sites

I have seen the patch cable be defective which won't let you do the setup properly. Another guy had a similar problem and one of his sounds wasn't named right with a 3 digit number and a space between the number and the sound name. Also be sure you don't have a duplication on one of the numbers. Someone already mentioned being sure you have the ecaller and the remote on the same channel.

Share this post


Link to post
Share on other sites

+1

If you haven't fixed it, I know a guy that makes some badarse hand calls.... out of pvc pipe or something...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0